IT Computer/Mac

Eclisepe ) Node.js version could not be determined 해결하기

📝 작성 : 2021.05.11  ⏱ 수정 : 
반응형

 

Eclipse에서 자꾸 Node.js 관련 에러가 발생하여 이클립스가 버벅이는 현상이 나타났습니다.

 

일단 제일 먼저 brew를 통해 Node.js를 설치해줍니다.

 

-Dorg.eclipse.wildwebdeveloper.nodeJSLocation=$(which node)

위의 내용을 추가 한 뒤에 다시 실해해봅니다.

Node.js 16 버전은 지원이 안된다고 합니다..

그래서 이번엔 node를 삭제 한 뒤에 node14 버전을 지정해서 설치했습니다. node14 버전은 메이저 버전이 아니라서 ~/.zshrc에 아래 내용들을 추가 해 주어야 합니다.. 애증의 전자정부..

export PATH="/opt/homebrew/opt/node@14/bin:$PATH"
export LDFLAGS="-L/opt/homebrew/opt/node@14/lib"
export CPPFLAGS="-I/opt/homebrew/opt/node@14/include"

vim 에디터로 위의 내용을 추가 하고 (vi ~/.zshrc 해서 아래 추가 후 wq 로 저장 후 나가기)

터미널을 껐다 켜고 which node 했을때 잘 잡히면 설정이 잘 된 것 입니다.

 

node 위치를 잘 못잡는다면 아래처럼 강제로 잡아 줄 수도 있습니다만, 저는 ${which node}를 추천합니다.

-Dorg.eclipse.wildwebdeveloper.nodeJSLocation=/opt/homebrew/Cellar/node@14/14.16.1_1/bin/node

 

더이상 경고가 발생하지 않습니다. 쾌적한 환경에서 코딩 할 수 있습니다!

반응형